Ssh access rejected until re-login; no prompt at ssh time

Hey, I got tailscale --ssh set up on my tailnet yesterday, and it was awesome! This morning, less so, as when I tried to ssh from my mac to my linux machines, I get this message

$ ssh machine-name
Rejected. Source key is either not authorized or was revoked.
Connection to machine-name closed.

Uh… what do I do? I have two machines that exhibit this symptom. I don’t have any ACLs set explicitly, so I’m using the Personal upgraded set of ACLs.


Update: I logged out and logged back in on the Tailscale Mac app and I got in, so I’m not blocked any more. I expected to be prompted to do so, rather than rejected outright, though…

1 Like

Following up, I’ve found that the experience over the last few days has much more consistently asked me to authenticate, and I haven’t had to manually do that work.

1 Like

+1, I just ran into the same issue and re-authenticating on the Mac app resolved the issue.

1 Like

same here, fix descripted above worked for me