Request - FireTV client

Tailscale is awesome to get past my Carrier Grade NAT for my cell phone. I go on business trips often, and would love to have an Android TV (Fire TV) version to access my collection while on the road.

Not sure the correct way to request this, so here it is.

Thank you!

Out of interest, why does the CGNAT on your phone affect your access to other devices? You should still be able to get out of that NAT to another device, provided you can port forward from that.

The CGNAT is part of my ISP (T-Mobile). It is in between my Jellyfin server at home (behind the CGNAT) and my cell phone and FireTV stick when away from home.

I have filed a feature request here. I can’t provide any timeline for when this will be implemented, however it is now in our backlog.

In the meantime you might want to try using the APK from f-droid: Tailscale | F-Droid - Free and Open Source Android App Repository. You’ll need to enable developer mode on your FireTV though.

Thank you! I tried the native Android Tailscale app I pulled from my phone, but it didn’t work, just blanked the screen for a second.

I will report back if I get it working.

Try the F-Droid build. It doesn’t have some Google libraries bundled in. The Google library bundle not being present is known to make the Google Play version of Tailscale render as a black screen on some Android devices.

Alright, I have some great news and some ok news.

First the great news: It works! The F-Droid version allows me to connect and participate in the VPN mesh network with my FireTV 4k Stick, yay!

Now for the ok news. It appears none of the buttons are selected by default signing up or using, so the remote will not select the button and I cannot navigate to the button using the d-pad. I was able to get past this by installing the mouse toggle app, allowing my remote to emulate a mouse cursor and select the buttons.

Obviously, not ideal, but workable. :slight_smile:

Hey all,
Closely related… I just went out and bought the Google Cromecast with Android TV. I tried to install the F-Droid version of Tailscale onto it and (using mouse toggle) I was able to get to the “sign in” page. Unfortunately, when I click on Sign in, a popup declares “You don’t have an app that can do this” and I cannot get any farther.

I am hopeful, this is a permissions tweak or something someone has hit before. Any Ideas?


It is trying to redirect to a browser to go through the OAuth signin. Android TV does not have a browser installed by default, and I think that is the app it is referring to.

@DGentry you are awesome. :slight_smile: Installed the puffin browser and, voila connected right up!

Thank you!


I found some additional guidance for those who land on this page like I did trying to sort out the details from the above comments just trying to find a solution. Hopefully this is helpful until there is a more straightforward way to get TailScale on Fire Sticks.