PC not using Tailscale's DNS settings

I have PiHole running on a linux server that I use Tailscale to access. I point the nameservers to the linux server’s Tailscale ip address and override local DNS enabled. On my phone and all my friend’s devices, PiHole works perfectly and the devices show up as a client. On one of my other friend’s pc, he had the same issue, but reinstalling it seemed to fix it for him.

On my pc though, it does not work no matter what I seem to do. I’ve tried reinstalling and deleting the config folder. I’m using DHCP on my pc if that helps. It is obviously a problem with my config, but I cant seem to figure it out.

Tailscale Preferences: