Newby...accessing specific computer on my network

Hi All,
Total newbie here on Tailscale. I have a network with three computers, one iPhone, and three Synology NAS. I have installed Tailscale on all three computers, my iPhone, and the NASs.
When I look at the “machines” list for Tailscale, I can see all but one of the devices above, and all visible show “connected”. The one computer I can not “see” is located behind a switch (however, the three NASs are located behind the same switch and I can see them.)
As mentioned above, I have installed Tailscale on all devices.
Can anyone tell me what I am doing wrong…or what I need to do?
Note: I can see/access this “invisible” computer using regular Windows 10 features.

Hi! I am also a newbie. We have a tailscale mesh.The company’s headquarters is a Synology NAS.MACs easily add tailscale to the VPN, as do iPhones and Android phones.We access all of them and see the directories on the NAS from each of them. Win 11 machines also appear in the machine room and connect.However, nothing happens when I click on the icon, and I can only access the NAS from the browser, not the folders directly, even though I need it to work. What I have to do?

If it’s not showing in the Tailscale control page you probably want to check it’s connected correctly. I had a user who has logged into their personal account rather than the company one on more than one occasion so while they were connected to Tailscale, they weren’t connected to the company network.
If unsure, log out and log in again or use a key from the control page to log it in.

Nicola - maybe check your DNS is working. Windows is really annoying about what it picks up and browsers are not always the same as the system. Try accessing the NAS directly by the Tailscale IP address and see if that works better then work out from there to debug.

1 Like

I seem to have solved the previous problem. Now I have a new one. When I copy the IP address and paste it in my browser address field, I get the following message:
“Your website is not set up yet.” What am I missing?
Edit: I failed to mention, I am trying to connect from my windows 10 laptop to one of my NAS (which has Tailscaled installed also.)

Sounds like an issue on the NAS - the default port for the synology is 5000 (http) and 5001 (https) so check you’ve put that on there to get to the Synology page.
Normally, I think 80 or 443 will redirect you there but possibly you’ve got one of the web server apps installed - that could be using port 80 or 443, not got anything set up yet and be overriding the default behaviour. Possibly. Check through the settings on the control panel and see if everything is correct.

Spidge, Thanks for the suggestions. In fact, it was the port being left off which generated the problem. I can now access each of my three NAS via their Tailscale IP address + port 5000. Oddly enough though, I can not access them via port 5001.
I still can not access my laptop or HTPC (each running windows 10, either from one Windows machine to another or from any of my NAS). Any suggestions here?

Your suggestion about removing the web server app worked great. No port is now required to log into my NASs.
I still have not figured out how to log into my windows machines. Tailscale is operational on them and the admin console on the NASs and Windows machines show all are available. Any suggestion?

First thing to check (if possible) is whether you can access them without tailscale. Obviously that requires that they are both on the same local network. Presumably you’re talking about windows shares when you say ‘log into’ your windows machines. If they’re on separate networks and you can’t get to them locally, then check the windows settings to make sure the required services are running and the user in question has access.
I’m not sure what you’re trying to access the windows machines from, but try tailscale ping {winmachine} and plain ping {winmachine} if it’s something with a terminal to make sure you have a route through. If DNS is an issue, try the pings to the tailscale IP address (and then try to access them using the address).


Thanks for the response.

  1. Yes, I can access everything (NASs, Windows computers, iPhone) without tailscale (windows shares, Synology assistant)

  2. All are on the same network. The network consists of ISP supplied modem/router (in bridge mode). my own mesh router, two switches used to increase ethernet distribution points (all devices are on ethernet).

  3. Via CMD command I issued a tailscale status → the results were as follows:

tailscale status
windows 1 - idle
windows 2 - idle
iOS - offlline
NAS1 - idle
NAS2 -
NAS3 -

  1. From my laptop I had the following success/no success when pinging:

Windows 0 (machine I used to ping with)

Pinging Windows 1 machine – success

Pinging Windows 2 machine – success

Pinging iPhone and my three NASs – could not ping.

Any suggestions?