MacOS machine name shows as 'localhost'

I have two MacOS clients both are Big Sur. But on admin console, one of their machine name is shown as ‘localhost’.

I checked my system preference as well as run ‘hostname’ in terminal, both show correct host name which is not localhost.

Any idea?

That is indeed pretty weird. If you stop and restart the tailscale
app, does it still look the same?

I tried removing the machine from admin console and re-registering but still the same.

This may be an issue with our name formatting. Mind sharing your machine’s Tailscale IP with us so we can debug?

There’s nothing sensitive in your Tailscale IP so it’s safe to post here, or you can email us at support@ if you prefer.

That machine is offline now. Does it need to be online?

It doesn’t need to be online. It looks like the Tailscale client is picking up the wrong hostname, but I’m not sure why.

Is there anything else about your setup on that device that might be relevant? Is it a hackintosh? Is it running macOS server? What version of macOS is it running?

It is indeed a hackintosh which runs Big Sur. But my other one which doesn’t have this problem is also running hackintosh Big Sur.

I turned that machine on again and log into Tailscale. This time it shows correct hostname.

Gotcha. We don’t plan to officially support Hackintosh setups, so you may run into bugs like that from time to time. Reproducing a transient bug like this would be pretty difficult. If you’re able to reliably reproduce it on standard macOS, we can investigate further, but otherwise, I’d chalk this up to something strange in your setup.

You can circumvent some of these issue by using our new machine name feature: from the admin panel, you can set a “machine name” for a device that’s persistent. In the next Tailscale client update, it should appear in the device lists too.

Given this information, I think it would be informative for you to indicate in your docs that for Mac OS builds, tailscale is supported exclusively on certain hardware, and to specify the relevant hardware.

It’s not that Hackintoshes are explicitly unsupported, they’re just not explicitly supported or tested. We test on various version of macOS and various Apple hardware, but we assume that macOS will behave like macOS.

Is the host name coming from os.Hostname() call?

Is the host name coming from os.Hostname() call?