Illegal Instruction 4 when turning on subnet routes on macos

When following the Subnet routers setup instruction page at, I’m getting stuck on Step 2: Connect to Tailscale as a subnet router

When entering the line listed on that step into terminal, sudo tailscale up --advertise-routes=10.*.*.*/24, I get a response of: Illegal instruction: 4

I’ve tried the install on 2 different machines running different OS’s (High Sierra and Catalina) and they’ve both returned the same error. I have a VM running Ubuntu on one of these machines and I tried the install on that VM where I was able to get that working on it so I’m pretty sure I’m putting the right commands in the terminal.

Anything I might be missing?

I’ve tried:

  • Rebooting the macs
  • Uninstall/Reinstall
  • Turning the exit node on and off
  • Running the IPNExtension command in terminal which returns:
    /Applications/ Mach-O universal binary with 2 architectures: [x86_64:Mach-O 64-bit executable x86_64] [arm64] /Applications/ (for architecture x86_64): Mach-O 64-bit executable x86_64 /Applications/ (for architecture arm64): Mach-O 64-bit executable arm64

I just don’t get what I’m missing. I appreciate any help on getting this running as I’d rather run the subnet router on the main machines and not a VM if I can avoid it!