Help with Oracle linux 7.x


Anybody here who got Tailscale working on a Oracle linux 7.x ARM version ?

I have tried a coupel of things, but nothing really seams to work.
So wanted to check here, before i dig in too deep :slight_smile:



Nobody ?

Maybe somebody can explain if it’s being planned ?

Oracle Linux isn’t a distribution we directly support, but there are ARM binaries at which I’d expect to work.

I tried but could not get it working.
Oracle cloud, is offering 4 cores, and 24 gb for free, on Oracle Linux running ARM.
So it opened a nice usecase, for TailScale :slight_smile:

Other than that, i fully understand not supporting it.

The following worked for me.

$ wget
$ tar xvfz tailscale_1.10.0_arm64.tgz
$ cd tailscale_1.10.0_arm64

Then follow instructions here:


sudo tailscaled --state=tailscaled.state

I then went to my admin page and generated a one-off pre-auth key (Auth keys · Tailscale). In another window (I installed screen so that I can have long running shell terminals)

sudo ./tailscale up --authkey tskey-XXXXXXXXXXXXXXXXXXXXX

This was enough to get my machine on my tailscale network. In an ideal world I would then use the supplied systemd scripts (Download · Tailscale) to ensure that the service restarts on reboot.

Oracle Linux 7.x seems to act like Centos 7.x. I was able to provision an Oracle cloud instance and then install Tailscale using the Centos 7 instructions. I will see about updating the packages server to add Oracle Linux to the list of generated package instructions.

1 Like

I can confirm that the CentOS instructions work.

I have good news! I have added Oracle Linux to the packages server here. I also added instructions to the website’s download page. If you are using the CentOS repo you shouldn’t need to take any action, but you can change it over to the Oracle Linux repo if you want.