Exit node not showing up on adminpage

Tailscale version: 1.8 on proxmox and 1.6 in LXC
Proxmox 6.4.5 and debian in LXC container.

I installed Tailscale on a debian LXC container and I didn’t get it to work. Enabled ip forwarding but I still get the message that it can’t relay traffic.

As I thought it might be a restriction of the container I installed it directly on Proxmox instead. Enabled ip forwarding there. But the command sudo tailscale up --advertise-exit-node . Does not seem to do anything. In the admin page it does not show up as an exit node. Restarting the whole server did not change this.

I installed Wireguard on another VPN and that is working fine. Any ideas what it could be?

One thing it might be: Tailscale checks that both IPv4 and IPv6 forwarding are enabled, even if you don’t really use IPv6 and wouldn’t notice.

To enable both in /etc/sysctl.conf:


Containers can support being subnet relays, there isn’t a restriction. You do have to approve the routes in the admin panel at https://login.tailscale.com/admin/machines, there will be a small exclamation point next to the Exit Node or relay label if it has not yet been approved by an admin.

I don’t immediately know what was going wrong with Proxmox. --advertise-exit-node should work.

Ok it suddenly started working but now my adguard dns ip adresses don’t do anything when I use them as a nameserver in the admin console.

Also how can I acces my proxmox page? Normally I use
to acces that but that is not working with Tailscale on.
With wireguard however it does work.

Do I need to install Tailscale to every VM to get it to work?

Edit: Never mind with enabling subnet routing it worked…

Regarding glad to hear that a subnet router allows access.

A number of us have installed Tailscale on proxmox systems, and use the 100.x.y.z:8006 address to access it.