DNS failing for some dns names

I’m using the app store version (version = 1.38.3), with default settings (preferences = all 4 set to on), no subnet routing or anything fancy in my network.
So far as I can tell this all worked in the last version.

Sometimes dns resolution isn’t working via the default resolve from the system, but is working correct when asking the dns server directly. I get this fairly instant when using Microsoft Teams, it starts failing after a few minutes to resolve presence.teams.microsoft.com. It works instantly again if I stop tailscale or set “use tailscale dns settings” to off.

% ping presence.teams.microsoft.com
ping: cannot resolve presence.teams.microsoft.com: Unknown host

But it resolves correctly via dig/nslookup:
% dig +short presence.teams.microsoft.com

I already tried to set different dns servers in my system settings for my wi-fi, but this doesn’t resolve the issue. Is there anything else I could provide/test or is this already known somewhere?

Somehow this is related to Cloudflare DNS I have now tested with another DNS (the one from my provider) and it works flawlessly.

I’m even more unsure what’s causing the issue. doesn’t have any problems on it’s own to resolve those domains.