Connect To PLC Via Subnet Router

I’m trying to connect a PLC to my Tailscale network via a Windows computer acting as a subnet router, and I’m not having much success getting it to work. Apologies in advance if this question has been asked and solved elsewhere, I’m a bit of a newbie when it comes to networking details and I haven’t been able to find any search results related to my particular problem.

My setup is this:

  • Tailscale installed on a Windows computer
  • The Windows computer is connected to the LAN/internet via wifi using a typical home router (ip address: 192.168.1.12, subnet mask: 255.255.255.0, default gateway: 192.168.1.1 (i.e. the router))
  • The PLC is connected to the Windows computer via an ethernet cable

Normally, the Windows computer can communicate with the PLC over the ethernet cable successfully using default networking settings on Windows. I just plug the ethernet cable into the computer, and the PLC assigns itself an IP address (169.254.60.78) with subnet (255.255.0.0), which I can use to communicate with it without issues. The Windows computer has an IP address of 169.254.15.107 on this ethernet adapter.

When I try to add the PLC to the Tailscale network via subnet routing is when I run into issues. I have been attempting to do this with the following command: tailscale up --advertise-routes=169.254.0.0/16

When I run that command, the Windows computer can no longer communicate with the PLC. Additionally, I cannot connect to the PLC from other computers via Tailscale. I am still attempting to make this connection with the PLC’s original IP address of 169.254.60.78, which I understand to be correct. If I bring tailscale back down with tailscale down then the Windows computer can immediately connect to the PLC again.

Is there something obvious I’m missing here? Is this even a supported scenario on Windows? If anyone has advice or suggestions on additional information I can provide to help diagnose the problem here it would be greatly appreciated.