Authkey Connection issue

Hey Community :wave:

I started working with Tailscale. Pretty nice so far. But I got an issue I wasn’t able to solve:

I wanna use tailscale to connect headless devices (raspbian, ubuntu). Therefore I want to use up —Authkey=.

Now the thing is: on devices that I initially logged in with browser support, up —Authkey= is working (I guess because I was still logged in?). When I log out or try up —Authkey= directly on a new device I don’t get connection - also no error. Just nothing happens.

I guess I miss something? Looking forward for your help.


For the systems which were never logged in with a browser and nothing happens: can you paste the “tailscale up” command you are using? Please don’t paste the authkey into the forum, just replace it with “AUTHKEY”.

For the systems which were logged in with a browser first: you are likely hitting Tailscale --auth-key doesn't force a re-auth using that authkey. · Issue #1133 · tailscale/tailscale · GitHub, where --force-reauth (or logout) has to be specified to get it to give up the login credential it got via the browser and use the authkey instead.

Hey @DGentry

thank you for answering.

I used same command for sudo tailscale up --authkey="AUTHKEY"

When I logged in with browser (sudo tailscale up) the usage of --authkey worked afterwards. BUT when I logged out and removed device in browser and retried with same auth key, it just gets stuck and nothing happens.

I tried with --force-reauth but that didn’t work as well.

Let me know if I may provide any other information to figure out what’s the issue.

If you can send the email/GitHub account used on the Tailnet to we can look into what is happening.

Solved - thanks. Looks like AuthKey was invalid - just didn’t get how :thinking: